DigiCert Alert - CertCentral Products Disabled - Preventing Certificate Management
Incident Report for DigiCert
Resolved
This incident has been resolved.
Posted Feb 24, 2020 - 21:02 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 24, 2020 - 20:09 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 24, 2020 - 19:00 UTC
Investigating
DigiCert - CertCentral Products Disabled - Preventing Certificate Management

We are currently experiencing a technical problem with our CertCentral system and are working to resolve the issue as quickly as possible.

CertCentral Products Disabled - Preventing Certificate Management

We are tracking this issue under Case# 01847434

If you have any questions please feel free to reach out to us:

Telephone: Call us

Chat: Chat with us

Email: Message us

DigiCert Support
Posted Feb 24, 2020 - 18:34 UTC
This incident affected: digicert.com and Cert Central.