DigiCert Alert - Connectivity to digicert services unreachable from some countries
Incident Report for DigiCert
Resolved
This incident has been resolved.
Posted Aug 30, 2020 - 17:46 UTC
Monitoring
Our provider has implemented a fix and we have seen recovery on this issue. We continue to monitor this and will update this page accordingly if the situation changes.
Posted Aug 30, 2020 - 15:51 UTC
Update
Our provider continues to work on a resolution to this issue. We are in contact with them and will share and update once available.
Posted Aug 30, 2020 - 15:03 UTC
Identified
DigiCert Website Security Alert - Connectivity to digicert services unreachable from some countries

We are currently experiencing a technical problem with our connectivity to digicert services from some countries and are working to resolve the issue as quickly as possible.

We are tracking this issue under Case# 02184514

Telephone: Call us

Chat: Chat with us

Email: Message us

We apologize for any inconvenience this may cause you.

DigiCert Support
Posted Aug 30, 2020 - 11:36 UTC
This incident affected: CertCentral (CertCentral Console) and digicert.com.