DigiCert Revocation Incident (CNAME-Based Domain Validation)
Incident Report for DigiCert
Resolved
This incident has been resolved.
Posted Jul 30, 2024 - 22:19 UTC
Identified
We have an important update regarding the ongoing certificate revocation incident: https://www.digicert.com/support/certificate-revocation-incident

DigiCert has been actively engaged with customers impacted by this incident. Many of these customers have been able to replace their certificates. Unfortunately, some customers operating critical infrastructure are not in a position to have all their certificates reissued and deployed in time without critical service interruptions.

To avoid disruption to critical services, we have engaged with browser representatives alongside these customers over the last several hours. Based on these discussions, we are now in a position to delay revocations under exceptional circumstances.
If you have not replaced your certificates yet, please send an email to delayed-revocation-request@digicert.com with the following information immediately:

1. CertCentral Account ID
2. Exceptional circumstances requiring revocation delay
3. Planned completion date, no later than Saturday, August 3rd 2024, 19:30 UTC

With this information we will file a delayed revocation bug with the browsers. Unless we hear from you by Wednesday, July 31st 2024, 19:30 UTC we will assume your certificates have been replaced and revoke them.

All impacted certificate serial numbers will continue to be listed in your DigiCert portal and will be removed once revoked. All certificates impacted by this incident, regardless of circumstances, will be revoked no later than Saturday, August 3rd 2024, 19:30 UTC.

Thank you all for your support and help through this urgent issue.
Posted Jul 30, 2024 - 22:00 UTC
This incident affected: CertCentral Global and EU (CertCentral Console (Global)).