DigiCert Alert - Cert Central DV SSL lifecycle
Incident Report for DigiCert
Resolved
This incident has been resolved.
Posted Oct 21, 2020 - 04:41 UTC
Investigating
DigiCert Website Security Alert - Cert Central DV SSL lifecycle

We are currently experiencing a technical problem with our Cert Central DV SSL Lifecycle system and are working to resolve the issue as quickly as possible.

DV SSL certificate lifecycle functions (enrol,renew and reissue) unavailable at this time.

We are tracking this issue under Case# 02267545

Telephone: Call us

Chat: Chat with us

Email: Message us

We apologize for any inconvenience this may cause you.

DigiCert Support
Posted Oct 21, 2020 - 03:06 UTC
This incident affected: CertCentral (CertCentral Console).