[Statuspage]identified - DigiCert Cert Central Alert - Some accounts experiencing delayed certificate issuance
Incident Report for DigiCert
Resolved
This incident has been resolved.
Posted Feb 21, 2020 - 17:02 UTC
Investigating
Some customer Cert Central accounts may be experiencing a technical problem certificate life-cycle functionality (enrollment, renewals, replacements) or delayed certificate issuance and we are working to resolve the issue as quickly as possible.

While we work to restore the functionality to these accounts to be fully operational, you can contact us through:

Telephone: Call us

Chat: Chat with us

We apologize for any inconvenience this may cause you.

DigiCert Website Security Support
Posted Feb 21, 2020 - 16:31 UTC