DigiCert Alert - CertCentral Outage
Incident Report for DigiCert
Resolved
This incident has been resolved.
Posted Jan 13, 2021 - 23:29 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 13, 2021 - 21:46 UTC
Update
We have identified that this is also causing an outage for our DigiCert Direct customers.
Posted Jan 13, 2021 - 21:25 UTC
Identified
We continue to see issue with CertCentral, not all changes improved our services, continuing to implement a fix.
Posted Jan 13, 2021 - 21:14 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 13, 2021 - 19:54 UTC
Identified
We continue to see issue with CertCentral, not all changes improved our services, continuing to implement a fix.
Posted Jan 13, 2021 - 18:59 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 13, 2021 - 18:28 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 13, 2021 - 18:22 UTC
Update
Impact involves CertCentral UI and API services, which could affect validation and certificate issuance. We are tracking this incident under case #02373318
Posted Jan 13, 2021 - 18:01 UTC
Investigating
DigiCert Alert - CertCentral Outage

We are currently experiencing a technical problem with our CertCentral system and are working to resolve the issue as quickly as possible.

Telephone: Call us

Chat: Chat with us

Email: Message us

We apologize for any inconvenience this may cause you.

DigiCert Support
Posted Jan 13, 2021 - 17:57 UTC
This incident affected: CertCentral (CertCentral API, CertCentral Console, Discovery and Automation, ACME) and DigiCert Direct Cert Portal (Direct Cert Portal API, Direct Cert Portal Console).