DigiCert Alert - Domain Management Services Failure
Incident Report for DigiCert
Resolved
This incident has been resolved.
Posted Mar 31, 2020 - 14:37 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 30, 2020 - 19:27 UTC
Investigating
We are currently experiencing a technical problem with our Domain Management system and are working to resolve the issue as quickly as possible.

While our engineering team works at fixing the issue please feel free to reach out to us:
Telephone: Call us

Chat: Chat with us

Email: Message us

We apologize for any inconvenience this may cause you.

DigiCert Support
Posted Mar 30, 2020 - 17:10 UTC
This incident affected: digicert.com and Cert Central.