CC EU API degraded performance

Incident Report for DigiCert

Resolved

This incident has been resolved.
Posted Sep 04, 2025 - 00:54 UTC

Investigating

We are currently investigating this issue
Posted Sep 04, 2025 - 00:29 UTC
This incident affected: CertCentral Global and EU (CertCentral EU API).