DigiCert Alert - Chat and Email System
Incident Report for DigiCert
Resolved
This incident has been resolved.
Posted Dec 30, 2020 - 08:57 UTC
Investigating
We are currently experiencing a technical problem with our Chat and Email System system and are working to resolve the issue as quickly as possible.

Our 3rd party company that we use for our Chat and email portal is currently having an intermittent issue. The system is not fully functional which will delay our response times. Please reach out to us via telephone if it is urgent.

While we work to restore access to our Chat and Email System, you can contact us through:

Telephone: Call us

We apologize for any inconvenience this may cause you.

DigiCert Support
Posted Dec 30, 2020 - 07:24 UTC
This incident affected: Digicert Services (Live Chat Support, DigiCert Support Email System).