DigiCert Alert - Cert Central
Incident Report for DigiCert
Resolved
This incident has been resolved.
Posted Sep 08, 2020 - 22:01 UTC
Update
We are continuing to monitor for any further issues.
Posted Sep 08, 2020 - 21:24 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 08, 2020 - 21:23 UTC
Investigating
DigiCert Website Security Alert - Cert Central

We are currently experiencing a technical problem with our Cert Central system and are working to resolve the issue as quickly as possible.

Users are unable to login to Cert Central accounts.

We are tracking this issue under Case# 02201509

Telephone: Call us

Chat: Chat with us

Email: Message us

We apologize for any inconvenience this may cause you.

DigiCert Support
Posted Sep 08, 2020 - 21:08 UTC
This incident affected: CertCentral (CertCentral Console) and digicert.com.