Issue with Dutch phone line

Incident Report for DigiCert

Resolved

This incident has been resolved.
Posted Nov 19, 2025 - 14:48 UTC

Identified

The Dutch Support phoneline system is having issue and we are working to fix the same. We request all NL customers, including Lawyer Card customers, to reach out to support via email at dc1.standard.support@digicert.com, until the issue is resolved
Posted Nov 19, 2025 - 11:08 UTC
This incident affected: Digicert Services (Telephony System).