Document Trust Manager (Netherlands and Switzerland instances) timeout

Incident Report for DigiCert

Resolved

All the affected customers confirmed that they are no more seeing timeouts during signing
Posted Nov 13, 2025 - 14:29 UTC

Monitoring

A fix has been implemented and the signings are completed successfully without any timeouts.
Posted Nov 12, 2025 - 17:28 UTC

Investigating

Document Signing applications using CSC endpoints are experiencing intermittent timeout during signing operations. We are investigating with cross-functional teams to identify the cause of the issue.
Posted Nov 12, 2025 - 07:58 UTC
This incident affected: DigiCert ONE Switzerland (Document Trust Manager (Switzerland)) and DigiCert ONE Netherlands (Document Trust Manager (Netherlands)).