DigiCert Alert - Cert Central SSL Lifecycle
Incident Report for DigiCert
Resolved
This incident is now resolved
Posted Mar 03, 2020 - 00:58 UTC
Monitoring
A fix has been implemented and we are now monitoring for stability.
Posted Mar 03, 2020 - 00:35 UTC
Identified
DigiCert Website Security Alert - Certificate Central Lifecycle

We are currently experiencing a technical problem with our Cert Central system and are working to resolve the issue as quickly as possible.

SSL Certificate lifecycle (enrollments, replacements, renewals) will be impacted at this time.

We are tracking this issue under Case# 01863304

Telephone: Call us

Chat: Chat with us

Email: Message us

We apologize for any inconvenience this may cause you.

DigiCert Support
Posted Mar 02, 2020 - 23:31 UTC
This incident affected: Cert Central.