DigiCert Alert - CertCentral Services Outage
Incident Report for DigiCert
Resolved
This incident has been resolved.
Posted Jun 09, 2020 - 20:25 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 09, 2020 - 17:50 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 09, 2020 - 17:45 UTC
Update
We are continuing to investigate this issue. You may see issues affecting both UI and API services at this time.
Posted Jun 09, 2020 - 17:38 UTC
Investigating
DigiCert Alert - CertCentral Services Outage

We are currently experiencing a technical problem with our CertCentral Services system and are working to resolve the issue as quickly as possible.

We are tracking this issue under Case# 02050610

Telephone: Call us

Chat: Chat with us

Email: Message us

We apologize for any inconvenience this may cause you.

DigiCert Support
Posted Jun 09, 2020 - 17:18 UTC
This incident affected: digicert.com and Cert Central.