Document Trust Manager (Netherlands and Switzerland instances) timeout

Incident Report for DigiCert

Resolved

This incident has been resolved.
Posted Nov 12, 2025 - 01:02 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 11, 2025 - 21:59 UTC

Investigating

Document Signing applications using CSC endpoints are experiencing intermittent timeout during signing operations. We are investigating with cross-functional teams to identify the cause of the issue.
Posted Nov 11, 2025 - 10:08 UTC
This incident affected: DigiCert ONE Switzerland (Document Trust Manager (Switzerland)) and DigiCert ONE Netherlands (Document Trust Manager (Netherlands)).