DigiCert/QuoVadis Alert - DC1 CH DTM down
Incident Report for DigiCert
Resolved
This incident has been resolved.
Posted Feb 06, 2024 - 08:34 UTC
Update
We are continuing to monitor for any further issues.
Posted Feb 06, 2024 - 08:14 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 06, 2024 - 08:13 UTC
Investigating
DigiCert/QuoVadis Alert - DC One CH DTM down

We are currently experiencing a technical problem with our DC One CH DTM system and are working to resolve the issue as quickly as possible.

DC One CH customers are unable to sign documents.

We are tracking this issue under Case# 03743206

Telephone: +41 71 228 98 98

Email: support.ch@digicert.com

We apologize for any inconvenience this may cause you.

DigiCert/QuoVadis Support
Posted Feb 06, 2024 - 08:03 UTC
This incident affected: DigiCert ONE Switzerland (Document Trust Manager (Switzerland).).