[Statuspage]scheduled - Upcoming Server Maintenance
Incident Report for DigiCert
Resolved
This incident has been resolved.
Posted Feb 21, 2020 - 17:01 UTC
Investigating
EDITED: On September 22, 2019 from 08:30 to 10:30 UTC, we’ll be performing routine server maintenance. During this time, access to CertCentral and APIs will be spotty or non-existent. We’ll restore full access as quickly as possible.

Make sure high priority and urgent renewals, new, and reissue orders are handled outside this scheduled maintenance window.
Posted Feb 21, 2020 - 16:31 UTC