NL | DigiCert Document Trust Manager | Signing unavailable

Incident Report for DigiCert

Resolved

The incident has been resolved and signings are going through fine.
Posted Mar 18, 2026 - 16:35 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 18, 2026 - 15:22 UTC

Investigating

We are currently experiencing an issue where document signing requests are failing. Users attempting to sign documents will receive an error and signatures will not be applied.

Our engineering team has been notified and is actively investigating the root cause.
Posted Mar 18, 2026 - 15:00 UTC
This incident affected: DigiCert ONE Netherlands (Document Trust Manager (Netherlands)).