DigiCert Alert - System Latency
Incident Report for DigiCert
Resolved
This incident has been resolved.
Posted Aug 13, 2020 - 14:57 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 13, 2020 - 13:26 UTC
Investigating
DigiCert Website Security Alert - System Latency

We are currently experiencing a technical problem with System Latency and are working to resolve the issue as quickly as possible.

We are tracking this issue under Case #02155368

Telephone: Call us

Chat: Chat with us

Email: Message us

We apologize for any inconvenience this may cause you.

DigiCert Support
Posted Aug 13, 2020 - 08:59 UTC
This incident affected: CertCentral (CertCentral Console) and digicert.com.