DigiCert Alert - Email Delivery System
Incident Report for DigiCert
Resolved
This incident has been resolved.
Posted May 08, 2020 - 03:20 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 08, 2020 - 00:19 UTC
Investigating
DigiCert Website Security Alert - Email Delivery System

We are currently experiencing a technical problem with our email delivery system and are working to resolve the issue as quickly as possible.

We are tracking this issue under Case# 01995397.

Telephone: Call us

Chat: Chat with us

Email: Message us

We apologize for any inconvenience this may cause you.

DigiCert Support
Posted May 07, 2020 - 23:45 UTC
This incident affected: digicert.com.