CertCentral EU : Issue with Validation flow causing delay in Cert issuance for few product certificates.

Incident Report for DigiCert

Resolved

This incident has been resolved.
Posted Apr 28, 2026 - 16:10 UTC

Monitoring

A fix has been implemented by the Engineering team and we are monitoring the performance of the validation workflow in the CertCentral EU for the following products.
Swiss Qualified Personal
Swiss regulated personal Org
Swiss regulated eSeal
AATL,
PKI Overheid,
PSD2 (QWAC/Seal),
EU qualified (all)
Posted Apr 28, 2026 - 10:47 UTC

Identified

We have identified an internal issue which could affect the validation flow for the following CertCentral EU products and cause delay in issuance. we are currently working with Engineering and SRE teams to resolve the same.
Swiss Qualified Personal
Swiss regulated personal Org
Swiss regulated eSeal
AATL,
PKI Overheid,
PSD2 (QWAC/Seal),
EU qualified (all)
Posted Apr 28, 2026 - 10:02 UTC
This incident affected: CertCentral EU (CertCentral EU API, CertCentral EU Console).