DigiCert Alert - Telephony System
Incident Report for DigiCert
Resolved
This incident has been resolved.
Posted Mar 23, 2020 - 20:52 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 23, 2020 - 17:44 UTC
Investigating
DigiCert Website Security Alert - Telephony System

We are currently experiencing a technical problem with our Telephony system and are working to resolve the issue as quickly as possible.

YOu may experience a delay when calling into our Support and Validation Center

In the mean time please contact us via chat and email:

Chat: Chat with us

Email: Message us

We apologize for any inconvenience this may cause you.

DigiCert Support
Posted Mar 23, 2020 - 13:59 UTC
This incident affected: CertCentral Global and EU (digicert.com Login (Global)).