Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 11, 2025 - 16:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Jan 07, 2025 - 01:49 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Jan 07, 2025 - 01:47 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Jan 07, 2025 - 01:47 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Jan 07, 2025 - 01:46 UTC
Scheduled
On 2025-01-11 from 16:00 to 18:00 UTC, DigiCert Europe and QuoVadis will be performing planned maintenance.
During this time, DigiCert Europe and QuoVadis services may be unavailable. These services will be restored as soon a maintenance is completed.
The DigiCert Europe 2025 maintenance schedule does not affect the QuoVadis CA systems. Maintenance for these systems is done via a different maintenance schedule.
Maintenance-related downtime for some DigiCert services
The ADSS signing service, PrimoSign signing service, and some QuoVadis services will be down during scheduled Europe maintenance.
How does this affect me?
ADSS signing service upgrade (Netherlands) – Four-hour downtime
Starts at 17:00 CET (UTC 16:00) Down for approximately four hours (until 21:00 CET / 20:00 UTC) Note: This upgrade extends downtime by two hours past the scheduled maintenance window.
ADSS signing service patching (Switzerland) – 10-minute downtime
Starts at 17:00 CET (UTC 16:00) Down for approximately 10 minutes
Legacy QuoVadis PrimoSign signing service maintenance – 60-minute downtime
Starts at 17:00 CET (UTC 16:00) Down for approximately 60 minutes
Document Trust Manager in the DigiCert® ONE Netherlands location Document Trust Manager in the DigiCert® ONE Switzerland location TrustLink Enterprise in Switzerland location
Schedule high-priority ADSS and PrimoSign document signings before or after the maintenance window. Schedule high-priority orders, renewals, and reissues before or after the maintenance window. Expect interruptions if you use the APIs for immediate certificate issuance and automated tasks.
Stay informed:
Subscribe to the DigiCert Status page for live maintenance updates, including email alerts for when maintenance starts and ends.
Restoration:
Services will be restored as soon as the maintenance is completed.
If you have any questions please feel free to reach out to us: