DigiCert Alert - Live Agent Chat Service
Incident Report for DigiCert
Resolved
This incident has been resolved.
Posted Jul 08, 2020 - 14:22 UTC
Identified
We are currently experiencing a technical problem with our 3rd party Live Agent Chat Service system and are working to with our vendor to resolve the issue as quickly as possible. Live Chat customer support will be unavailable during this time.

While we work to restore access to our Live Agent Chat Service, you can contact us through:

Telephone: Call us

Email: Message us

We apologize for any inconvenience this may cause you.

DigiCert Website Security Support
Posted Jul 08, 2020 - 08:06 UTC
This incident affected: CertCentral Global and EU (CertCentral Console (Global), digicert.com Login (Global), Certificate Issuing Service (CIS)) and Digicert Services (ocsp.digicert.com).