DC1 NL Prod : Slow processing of TLM API

Incident Report for DigiCert

Resolved

The response time has improved and customers confirmed recovery.
Posted Apr 15, 2026 - 14:08 UTC

Investigating

We have received reports from a few customers that the TLM API of DC1 NL prod instance are processing slowly. We are actively troubleshooting the issue with the Engineering team to identify the cause.
Posted Apr 15, 2026 - 09:34 UTC
This incident affected: DigiCert ONE Netherlands (Trust Lifecycle Manager (Netherlands).).