DigiCert PKI Platform 8 - Login issues

Incident Report for DigiCert

Resolved

This incident has been resolved.
Posted Mar 12, 2026 - 05:30 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 12, 2026 - 04:56 UTC

Investigating

We are currently investigating an issue impacting the ability to log into DigiCert PKI Platform 8 via the PKI-Manager UI Portal.

An update will be posted when available

We apologize for the disruption while we work to restore operations.
Posted Mar 12, 2026 - 04:42 UTC
This incident affected: Managed PKI (User Authentication) (PKI Platform 8).