Digicert PKIO CRL - not updated

Incident Report for DigiCert

Resolved

This incident has been resolved.
Posted Oct 03, 2025 - 15:19 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 03, 2025 - 15:10 UTC

Investigating

We have issues reported with Digicert PKIoverheid CRLs where it is observed that they are not updated and we are currently troubleshooting the issue with cross-functional teams to fix the same.
Posted Oct 03, 2025 - 14:58 UTC
This incident affected: Digicert Services (Certificate Revocation List (CRL)).