DigiCert Alert - Domain Validation Services
Incident Report for DigiCert
Resolved
This incident has been resolved.
Posted Mar 09, 2020 - 20:25 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 09, 2020 - 18:18 UTC
Investigating
DigiCert Alert - Domain Validation Services

We are currently experiencing a technical problem with our Domain Validation Services system and are working to resolve the issue as quickly as possible.

Domain Validation Services may not be functioning as expected, resulting in errors.

We are tracking this issue under Case# 01877618

Telephone: Call us

Chat: Chat with us

Email: Message us

We apologize for any inconvenience this may cause you.

DigiCert Support
Posted Mar 09, 2020 - 17:55 UTC
This incident affected: digicert.com, IoT Issuance Endpoints, and Cert Central.