CertCentral: Payments through credit cards are intermittently failing at the payment gateway

Incident Report for DigiCert

Resolved

Based on our analysis we found that all the legitimate transactions are going through fine and the errors were due to genuine failures.
Posted Sep 08, 2026 - 07:11 UTC

Investigating

We are currently investigating an issue affecting our payment gateway service. Transactions using newly added cards are currently failing, while transactions using existing cards may experience intermittent failures.
Posted Sep 08, 2026 - 05:49 UTC
This incident affected: CertCentral Global (CertCentral API (Global), CertCentral Console (Global), E-Commerce).