Digicert Alert - Subscription Accounts

Incident Report for DigiCert

Resolved

This incident has been resolved.
Posted Sep 25, 2025 - 15:29 UTC

Update

Unable to add products to cart on CertCentral EU Subscription Accounts
Posted Sep 25, 2025 - 13:16 UTC

Update

We are continuing to investigate this issue.
Posted Sep 25, 2025 - 12:18 UTC

Investigating

We are currently investigating the issue with CertCentral EU portal where access to the site is failing with 502 error.
Posted Sep 25, 2025 - 11:48 UTC
This incident affected: CertCentral EU (CertCentral EU Console).