Chat and Email System Degraded Performance
Incident Report for DigiCert
Resolved
This incident has been resolved.
Posted Aug 11, 2022 - 15:57 UTC
Monitoring
A fix has been implemented by our 3rd party vendor and we are monitoring the results
Posted Aug 11, 2022 - 10:11 UTC
Investigating
We are currently experiencing degraded performance and delayed response times in our 3rd party vendor Chat and Email systems. This is being investigated by this vendor and we will update accordingly.
Posted Aug 10, 2022 - 17:32 UTC
This incident affected: Digicert Services (Live Chat Support, DigiCert Support Email System).