DigiCert - Chat Support Offline from 4pm UTC (9am MST)

Incident Report for DigiCert

Resolved

This incident has been resolved.
Posted Feb 10, 2026 - 20:28 UTC

Investigating

We are currently upgrading our live chat service to our new Chat Messenger platform. During this transition, chat support is temporarily unavailable.
Our team remains available through alternate support channels, and we are working to restore chat functionality as quickly as possible.
We appreciate your patience while we make this improvement.
Posted Feb 10, 2026 - 15:33 UTC
This incident affected: Digicert Services (Live Chat Support).