DigiCert Alert - Cert Central SSL Lifecycle & API's
Incident Report for DigiCert
Resolved
This incident has been resolved.
Posted Nov 06, 2020 - 02:20 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 06, 2020 - 01:48 UTC
Investigating
DigiCert Website Security Alert - Cert Central SSL Lifecycle & API's

We are currently experiencing a technical problem with our Cert Central SSL Lifecycle & API's system and are working to resolve the issue as quickly as possible.

Cert Central SSL Lifecycle & API's are currently down

We are tracking this issue under Case# 02294331

Telephone: Call us

Chat: Chat with us

Email: Message us

We apologize for any inconvenience this may cause you.

DigiCert Support
Posted Nov 06, 2020 - 01:10 UTC
This incident affected: CertCentral (CertCentral API, CertCentral Console, Discovery and Automation) and digicert.com.