DigiCert Alert - Issuance API Latency
Incident Report for DigiCert
Resolved
This incident has been resolved.
Posted Sep 24, 2020 - 03:10 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 24, 2020 - 02:40 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 24, 2020 - 02:25 UTC
Investigating
DigiCert Website Security Alert - Issuance API Latency

We are currently experiencing a technical problem with our Issuance API system and are working to resolve the issue as quickly as possible.

We are tracking this issue under Case# 02228048

Telephone: Call us

Chat: Chat with us

Email: Message us

We apologize for any inconvenience this may cause you.

DigiCert Support
Posted Sep 24, 2020 - 01:49 UTC
This incident affected: CertCentral (CertCentral API, CertCentral Console), Enterprise (Managed PKI for SSL Console), and digicert.com.