Users are experiencing issues accessing the Swiss DigiCert one Instance
Incident Report for DigiCert
Resolved
This incident has been resolved.
Posted May 20, 2022 - 19:53 UTC
Update
We are continuing to monitor for any further issues.
Posted May 20, 2022 - 19:52 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 20, 2022 - 19:46 UTC
Investigating
When trying to access DigiCert One in Switzerland, the login screen never appears. We are investigating this issue.
Posted May 20, 2022 - 18:29 UTC
This incident affected: DigiCert ONE Switzerland (Account Manager (Switzerland), CA Manager (Switzerland), Trust Lifecycle Manager (Switzerland), IoT Trust Manager (Switzerland), Software Trust Manager (Switzerland), Document Trust Manager (Switzerland)).