DigiCert Alert - Validation Services
Incident Report for DigiCert
Resolved
This incident has been resolved.
Posted May 14, 2020 - 08:41 UTC
Investigating
DigiCert Website Security Alert - Validation Services

We are currently experiencing a technical problem with our Validation Services system and are working to resolve the issue as quickly as possible.

We are tracking this issue under Case# 02005599

Telephone: Call us

Chat: Chat with us

Email: Message us

We apologize for any inconvenience this may cause you.

DigiCert Support
Posted May 14, 2020 - 02:00 UTC
This incident affected: CertCentral (CertCentral Console).