DigiCert Alert - Unable to place DV orders in CertCentral
Incident Report for DigiCert
Resolved
This incident has been resolved.
Posted Jul 30, 2020 - 18:50 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 30, 2020 - 17:15 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 30, 2020 - 17:13 UTC
Investigating
We are currently experiencing a technical problem with our DV certificate orders and are working to resolve the issue as quickly as possible.

The following error is shown when placing any DV order in our CertCentral accounts : "An unknown error has occurred with your request."

We are tracking this issue under Case# 02135763

While we work to restore access to placing DV orders, you can contact us through:

Telephone: Call us

Chat: Chat with us

Email: Message us

We apologize for any inconvenience this may cause you.

DigiCert Website Security Support
Posted Jul 30, 2020 - 17:01 UTC
This incident affected: CertCentral (CertCentral Console).